Michael de Silva's Blog

Software Engineer. Rubyist and Roboticist.

Michael de Silva's Blog

Software Engineer. Rubyist and Roboticist.

Blog: Upgrading to Ruby 2

Today I decided to upgrade this blog to Ruby 2+ and along the way noticed my VPS was running 1.9.2 and one of the dependencies needed at least 1.9.3.

So I set about removing RMV via rvm implode; then performing a system-wide re-install

curl -sSL https://get.rvm.io | sudo bash -s stable

This was followed by installing the new version of ruby and installing Passenger

gem install passenger
passenger-install-apache2-module

From this point, it was simply a matter of following the instructions for updating Apache's passenger.load and passenger.conf files with the path to the new ruby (installed in /usr/local/bin/rvm), and restarting the Apache service.

comments powered by Disqus